Back to overview
Degraded

CDN, Audio is down

Mar 07 at 10:15am CET
Affected services
CDN, Audio

Resolved
Mar 07 at 10:21am CET

CDN, Audio recovered.

Created
Mar 07 at 10:15am CET

CDN, Audio is degraded.