Back to overview
Degraded
CDN, Audio is down
Mar 31, 2026 at 4:19am UTC
Affected services
CDN, Audio
Resolved
Mar 31, 2026 at 4:24am UTC
CDN, Audio recovered.
Affected services
Created
Mar 31, 2026 at 4:19am UTC
CDN, Audio is degraded.
Affected services