Back to overview
Degraded

CDN, Player and Editor Assets is down

May 20, 2026 at 12:00pm UTC
Affected services
CDN, Player and Editor Assets

Resolved
May 20, 2026 at 2:47pm UTC

CDN, Player and Editor Assets recovered.

Updated
May 20, 2026 at 2:41pm UTC

CDN, Player and Editor Assets is degraded.

Updated
May 20, 2026 at 12:05pm UTC

CDN, Player and Editor Assets recovered.

Created
May 20, 2026 at 12:00pm UTC

CDN, Player and Editor Assets is degraded.