Back to overview
Resolved

Player, Editor, API and CDN, Player and Editor Assets are down

Jul 12, 2026 at 2:07pm UTC
Affected services
CDN, Player and Editor Assets
Player, Editor, API

Resolved
Jul 12, 2026 at 2:12pm UTC

Player, Editor, API recovered.

Updated
Jul 12, 2026 at 2:11pm UTC

CDN, Player and Editor Assets recovered.

Created
Jul 12, 2026 at 2:07pm UTC

CDN, Player and Editor Assets and Player, Editor, API are degraded.